Plugin timed out while executing system call


#1

I’m getting once in a while "CRITICAL - Plugin timed out while executing system call

once in a while for any services from any servers from nagios.
i’m running the plugins using ssh
i searched the whole forum and nothing applies to my situation.

this is what i done to fix it.

  1. running the latest plugins.
  2. running the latest nagios
    3.tried with RSA,DSA keys.
  3. logs don’t tell me anything.

if i run the commands as nagios user they run fine, the problem is when nagios runs the command.
the weird is that it fix by itself after several minutes later.

any help please.


#2

I have this problem too. On one of my servers, about 3 times a week, I will get a CRITICAL message saying that the command timed out. 4-5 minutes later, it is fine. If you find out what this is about, please share.


#3

I found the problem of my servers, and this could be the problems for your as well.

most of my server are busy, running lots of processes and nagios server EXTERNAL COMMAND CHECK INTERVAL was often as possible by default causing it to stop or no to be able to process the result back to the server, and as soon reached the TIME OUT value produced “Plugin timed out while executing system call”

i change to be at least 3minutes or 180s
in the nagios.cfg
command_check_interval=180s
and restart the service, until now i haven’t have any of those problems anymore.

also you should check # TIMEOUT VALUES section.

i hope this help some one.


#4

I had “connection refused” and “Could not make ssl handshake” on a number of occasions. I fixed this by adding “cps = 500 5” in the /etc/xinetd.d/nrpe


#5

Hello…
I am monitoring 10 processes on remote server through check_by_ssh in nagios. 8 services works fine.
but in check_ping and check_ssh through ssh I am getting error "CRITICAL - Plugin timed out while executing system call"
These both works fine in command line… Only in nagios these have problem !!!

I tried by modifying “command_check_interval” = 180s (was -1) in nagios.cfg file…but didn’t work.
I tried by calling commands (check_ping and check_ssh through check_by_ssh) with option “-t 20” it didn’t work

how to resolve this? Does anyone have any idea?
please help …