Problem get service with special character


#1

Hi all, i’m using Nagios version 3.0.6 and i have problem with command check_nt, following is my command:

define service{
use generic-service
host_name winserver
service_description W3SVC
check_command check_nt!SERVICESTATE!-d SHOWALL -l MSSQL$MYSERVICE
}

with the service have normal name i can get service status normally, but with this service, because service name have special character $ caused i got problem with nagios reply back the service name like MSSQL so can not found the service from remote host, i had been tried something like MSSQL**$MYSERVICE or ‘MSSQL$MYSERVICE’ till got problem but on this time system reply back that can not found service MSSQL$MYSERVICE$** :shock: why have more $ character like this. How to solve this problem, any one can help me.


#2

I assume we are talking about nsclient++? You may get better responses at the nsclient forum.

a) I think there is a parameter to allow “nasty” characters in argument. At least for check_nrpe, maybe not for check_nt. Look in the ini file. If not working for _nt switch to _nrpe.
b) either way I think the best solution is to create an local alias in the ini file. Of course the there is a downside if you need to check a high number of server.


#3

ok thanks, i’ll try first