Problem with check_nrpe


#1

i have installed and configured check_nrpe
I have small doubt in checking it.
I have one server on which nagios runs and another system on which nrpe daemon is installed
I just installed nrpe plugin on the system on which nagios server is running
now to check whether check_nrpe is running which address should i give in the system to be monitored and the system which is moitoring

In the system which is to be monitored by nagios server i gave its own ip-address in file /etc/xinetd.d/nrpe as
only_from its own ip
to check nrpe i gave
/usr/local/nagios/libexec/chec_nrpe -H its own ip
its returning the nrpe edition number
Is it ok what I did?

If it is ok, what ip-address should i give in the system on which nagios is running.
I tried by giving both its own ip and the ip of the system to be monitored.
In the first case it returned "connection refused by host"
In the second case it returned “CHECK_NRPE: Error - Could not complete SSL handshake”

What is the error.
Please let me know what is the error and what should i do to resolve this?

thanks,
512


#2

Yes, that’s fine, and the return is correct: when the combination of check_nrpe and nrpe is working, that’s the expected answer => that means that your check_nrpe is able to contact your nrpe.

I don’t really understand the question, but the second case means that you’ve got a SSL problem between your server and your client.
Try to run both with the -n option (or even compile both of them with the --disable-SSL option).

Hope this helps


#3

Hi,
thanks for your reply.

Let me explain my second question in detail. In the system in which nagios is running(server), I gave the its own address beside only_from in /etc/xinetd.d/nrpe

then i gave the command as followed

/usr/local/nagios/libexec/check_nrpe -H Remote-host ip address

Then the error is
CHECK_NRPE: Error - Could not complete SSL handshake

Then I tried giving
/usr/local/nagios/libexec/check_nrpe -n -H remote host’s iip address

Then the error is
CHECK_NRPE: Error receiving data from daemon.

Why is this happening so?
Please help me to solve this error

Thanks,
512
I have tested by giving -n option also but it resulted in a new error.


#4

Hi,
How can we execute the step mentioned in this statement below

SSL is disabled. Make sure both the NRPE daemon and the check_nrpe plugin were compiled with SSL support and that neither are being run without SSL support (using command line switches)

I think the reason for above error is this. Please check this once.

Thanks,
512.


#5

I have my previous doubts cleared. Its working now.
but now, when I use
check_nrpe!check_ssh and all other service checks its retuning the error saying

Return code of 127 is out of bounds - plugin may be missing

I know that plugins are missing but i am not getting how to resolve this.
Should i add any thing in nagios.conf and nrpe.conf

Please check this once

Thanks,
512


#6

everything you need to know about nrpe:
nagios.sourceforge.net/docs/nrpe/NRPE.pdf

it should help you greatly (when you’ll have read this pdf, you won’t have to ask about nrpe.conf :))


#7

Hi,
Thanks Loose for your suggestion. I have read the documentation of NRPE. Its very good and now i got a complete idea on nrpe

Thanks,
512