Problem with install Nagios 3.0.5


#1

Hi,
I have a problem when I verify the sample nagios configurattion files…

When I run

/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Bash : /usr/local/nagios/bin/nagios : no such file or directory…

The /usr/local/nagios/bin/ folder is empty…

Thanks…


#2

Hi Germano,

can you give some more information about all the steps you have taken before you came to this point?

Tinus.


#3

I followed this command (red hat 9) :

  1. Don’t install nagios using RPM,instead download the source code tarballs of both Nagios and the Nagios plugins (visit nagios.org/download/ for links to the latest versions).
    wget osdn.dl.sourceforge.net/sourcefo … 0.3.tar.gz
    wget osdn.dl.sourceforge.net/sourcefo … .11.tar.gz
  2. Create Account Information
    Become the root user.
    su -l
  3. Create a new nagios user account and give it a password.
    /usr/sbin/useradd -m nagios
    passwd nagios
  4. Create a new nagcmd group for allowing external commands to be submitted through the web interface. Add both the nagios user and the Apache user to the group.
    /usr/sbin/groupadd nagcmd
    /usr/sbin/usermod -G nagcmd nagios
    /usr/sbin/usermod -G nagcmd apache
  5. Extract the Nagios source code tarball.
    cd ~/downloads
    tar xzf nagios-3.0.3.tar.gz
    cd nagios-3.0.3
    Run the Nagios configure script, passing the name of the group you created earlier like so:
    ./configure --with-command-group=nagcmd
  6. Compile the Nagios source code.

make all

Install binaries, init script, sample config files and set permissions on the external command directory.

make install

make install-init

make install-config

make install-commandmode

  1. Customize Configuration
    Sample configuration files have now been installed in the /usr/local/nagios/etc directory. These sample files should work fine for getting started with Nagios. You’ll need to make just one change before you proceed…
    Edit the /usr/local/nagios/etc/objects/contacts.cfg config file with your favorite editor and change the email address associated with the nagiosadmin contact definition to the address you’d like to use for receiving alerts.
    vi /usr/local/nagios/etc/objects/contacts.cfg
  2. Configure the Web Interface
    Install the Nagios web config file in the Apache conf.d directory.
    make install-webconf
    root@lvs2 nagios-3.0.3]# make install-webconf
    /usr/bin/install -c -m 644 sample-config/httpd.conf /etc/httpd/conf.d/nagios.conf
  3. Create a nagiosadmin account for logging into the Nagios web interface.
    htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin
    Restart Apache to make the new settings take effect.
    service httpd restart
  4. Compile and Install the Nagios Plugins
    Extract the Nagios plugins source code tarball.
    cd ~/downloads
    tar xzf nagios-plugins-1.4.11.tar.gz
    cd nagios-plugins-1.4.11
  5. Compile and install the plugins.
    ./configure --with-nagios-user=nagios --with-nagios-group=nagios
    make
    make install
    Start Nagios
  6. Add Nagios to the list of system services and have it automatically start when the system boots.
    chkconfig --add nagios
    chkconfig nagios on
    Verify the sample Nagios configuration files.
    /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

BUT THE /BIN FOLDER IS EMPTY !!

Thanks for your help !


#4

maybe your nagios executable file is not in that folder. Try to locate the file and then try to run it.

I don’t know what default directory is set in configure file, but you can check that and find where it put the executables.
Or you can use ./configure --prefix as described here:
nagios.sourceforge.net/docs/2_0/installing.html


#5

Ok… Done!!!

Thanks for all… :wink:


#6

[quote]Starting nagios:No directory, logging in with HOME=/
done.
[/quote]

can someone pls help me, i dont know what went wrong because the web/login interface didt appear