Problem with the ./configure --with-command-group=nagcmd


#1

I have an Ubuntu 7.06 install on which I would like to use Nagios 3.0.2. I have been following the “Quick Install for Nagios Ubuntu” and have completed all that is on the list such as;

sudo apt-get install apache2
sudo apt-get install build-essential
sudo apt-get install libgd2-xpm-dev

However when I run the ./configure --with-command-group=nagcmd it fails with the following;
root@pho02:/opt/tmp/downloads/nagios-3.0.2# ./configure --with-command-group=nagcmd
checking for a BSD-compatible install… /usr/bin/install -c
checking build system type… i686-pc-linux-gnulibc1
checking host system type… i686-pc-linux-gnulibc1
checking for gcc… gcc
checking for C compiler default output file name… configure: error: C compiler cannot create executables
See `config.log’ for more details.
root@pho02:/opt/tmp/downloads/nagios-3.0.2#

Please find the config.log following;
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure --with-command-group=nagcmd

---------

Platform.

---------

hostname = pho02
uname -m = i686
uname -r = 2.6.20-15-generic
uname -s = Linux
uname -v = #2 SMP Sun Apr 15 07:36:31 UTC 2007

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games

-----------

Core tests.

-----------

configure:1352: checking for a BSD-compatible install
configure:1407: result: /usr/bin/install -c
configure:1426: checking build system type
configure:1444: result: i686-pc-linux-gnulibc1
configure:1452: checking host system type
configure:1466: result: i686-pc-linux-gnulibc1
configure:1521: checking for gcc
configure:1537: found /usr/bin/gcc
configure:1547: result: gcc
configure:1791: checking for C compiler version
configure:1794: gcc --version </dev/null >&5
gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Copyright © 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:1797: $? = 0
configure:1799: gcc -v </dev/null >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: …/src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
configure:1802: $? = 0
configure:1804: gcc -V </dev/null >&5
gcc: ‘-V’ option must have argument
configure:1807: $? = 1
configure:1830: checking for C compiler default output file name
configure:1833: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:1836: $? = 1
configure: failed program was:
| /* confdefs.h. /
|
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:1875: error: C compiler cannot create executables
See `config.log’ for more details.

----------------

Cache variables.

----------------

ac_cv_build=i686-pc-linux-gnulibc1
ac_cv_build_alias=i686-pc-linux-gnulibc1
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnulibc1
ac_cv_host_alias=i686-pc-linux-gnulibc1
ac_cv_path_install=’/usr/bin/install -c’
ac_cv_prog_ac_ct_CC=gcc

-----------------

Output variables.

-----------------

BASEEXTRALIBS=’‘
BROKERLIBS=’‘
BROKER_H=’‘
BROKER_LDFLAGS=’‘
BROKER_O=’‘
CC=‘gcc’
CFLAGS=’‘
CGIEXTRAS=’‘
CHECKRESULTDIR=’‘
COMMAND_OPTS=’‘
CPP=’‘
CPPFLAGS=’‘
DEFS=’‘
ECHO_C=’‘
ECHO_N=’-n’
ECHO_T=’‘
EGREP=’‘
EXEEXT=’‘
GDLIBS=’‘
GLIB_INCLUDE=’‘
GLIB_LIBS=’‘
HTTPD_CONF=’‘
INITDIR=’‘
INSTALL=’/usr/bin/install -c’
INSTALLPERLSTUFF=’‘
INSTALL_DATA=’${INSTALL} -m 644’
INSTALL_OPTS=’‘
INSTALL_PROGRAM=’${INSTALL}‘
INSTALL_SCRIPT=’${INSTALL}‘
LDFLAGS=’‘
LIBOBJS=’‘
LIBS=’‘
LTLIBOBJS=’‘
MAIL_PROG=’‘
MOD_CFLAGS=’‘
MOD_LDFLAGS=’‘
OBJEXT=’‘
PACKAGE_BUGREPORT=’‘
PACKAGE_NAME=’‘
PACKAGE_STRING=’‘
PACKAGE_TARNAME=’‘
PACKAGE_VERSION=’‘
PACKDIR=’‘
PATH_SEPARATOR=’:‘
PATH_TO_TRACEROUTE=’‘
PERL=’‘
PERLDIR=’‘
PERLLIBS=’‘
PERLXSI_O=’‘
SET_MAKE=’‘
SHELL=’/bin/bash’
SNPRINTF_O=’‘
SOCKETLIBS=’‘
STRIP=’‘
THREADLIBS=’‘
TMPDIR=’‘
USE_EVENTBROKER=’‘
VERSION=’‘
XCDC=’‘
XCDH=’‘
XDDC=’‘
XDDH=’‘
XODC=’‘
XODH=’‘
XPDC=’‘
XPDH=’‘
XRDC=’‘
XRDH=’‘
XSDC=’‘
XSDH=’‘
ac_ct_CC=‘gcc’
bindir=’${exec_prefix}/bin’
build=‘i686-pc-linux-gnulibc1’
build_alias=’‘
build_cpu=‘i686’
build_os=‘linux-gnulibc1’
build_vendor=‘pc’
cgiurl=’‘
command_grp=’‘
command_user=’‘
datadir=’${prefix}/share’
exec_prefix=‘NONE’
host=‘i686-pc-linux-gnulibc1’
host_alias=’‘
host_cpu=‘i686’
host_os=‘linux-gnulibc1’
host_vendor=‘pc’
htmurl=’‘
includedir=’${prefix}/include’
infodir=’${prefix}/info’
init_dir=’‘
libdir=’${exec_prefix}/lib’
libexecdir=’${exec_prefix}/libexec’
localstatedir=’${prefix}/var’
lockfile=’‘
mandir=’${prefix}/man’
nagios_grp=’‘
nagios_name=’‘
nagios_user=’‘
nagiostats_name=’‘
oldincludedir=’/usr/include’
prefix=‘NONE’
program_transform_name=‘s,x,x,‘
sbindir=’${exec_prefix}/sbin’
sharedstatedir=’${prefix}/com’
sysconfdir=’${prefix}/etc’
target_alias=’’

-----------

confdefs.h.

-----------

#define PACKAGE_BUGREPORT “”
#define PACKAGE_NAME “”
#define PACKAGE_STRING “”
#define PACKAGE_TARNAME “”
#define PACKAGE_VERSION “”

configure: exit 77

I checked through the paths and made sure that the APT packages where installed. I just cannot seem to work out what is preventing this script to execute correctly.

Regards,

Aaron


#2

hi,
I think you did not follow the installation steps properly.
Check that once.
Cheers,
512