Problem with the Nagios internet interface... perhaps a cgi


#1

Hi,

I had a recent problem with nagios after it went crazy when I made some changes to the config files. I ended up running “make distclean” thinking it would help, but it only made it worse… that was when I lost the web interface of nagios. I have reinstalled and reconfigure nagios several times without any luck of getting nagios back to where it was before. And when I changed the configuration for the http service, it went crazy. I must have done something wrong when making the configuration. No idea what happened before I ran “make distclean”, but it is royally effed up. Here is a pic of the error when I try to access Nagios over the web interface:

img411.imageshack.us/my.php?imag … nntdx3.png

I saw the error with that said something about the .cgi file, but I am totally sure what I could do here. Any suggestions or ideas?

Read the edit below please

[EDIT: I forgot that the pic is in German, let me translate here real quick: Your request can not be answered, there was an internal error that occured on the Server. The Server is either overloaded or there is a problem with the CGI-Script]


#2

Never mind, I opened my mouth too soon. I fixed it after changing the permissions of the htpasswd.users file.