Problems displaying results in the webinterface


#1

Hi all,
I’ve installed Nagios-server on a Solaris system, without any problem. Done some configuration on the cfg-files, checked these and up it goes! Great work, so far.

I noticed that the replies of the active checks doesn’t get promoted to the webinterface, though they’re executed. I see the output of the checks in my $NAGIOSHOME/var/spool/checkresults, which got filled up with files containing check information (results and some additional info). But these result aren’t presented on the webinterface (like “Service Details”).

When I run the check in a passive mode (“Submit passive check result”), the webinterface isupdated.

In the nagios.log file there are lines recorded saying
"Warning: The check of service ‘’ on host ‘localhost’ looks like it was orhpaned (results never came back). I’m scheduling an immediate check of the service…".

Has anybody a clue on this?

Thanks in advance …

Nico


#2

Check in the nagios.cfg that these options are set to 1:
execute_service_checks=1
execute_host_checks=1

…and try to add this line in service definition:
active_checks_enabled 1

If non of the above works I would suggest an upgrade of the Nagios or re-install. 'Cause such errors with orphaned services appeared before and the reinstall solved the problem in some situations.


#3

Hi!

Thanks for the reply and sorry I was not able to react earlier.

I tried the suggested changes for the parameters, but it didn’t influence the behaviour of Nagios. I think the active checks are actually execture, but the webinterface isn’t updated. I come to this conclusion because there are file generated in the checkresults directory constantly.

Maybe I try a new installation. Keep you informed in this thread.

Greetings,
Nico