Problems while installing munin-node on centOS-6


#1

I am facing problem while installing munin-node on Xenserver 6.0.2 machine which uses centOS-6 as its OS. I have munin server running on another machine which has ubuntu 10.04 on it and I want Xenserver machine to be attached to this machine. But I am unable to install some dependencies of munin-node on Xenserver machine. On using command ‘yum -y install munin-node’, it shows following error:

munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: /usr/bin/ruby is needed by package munin-node-2.0.8-1.el5.noarch (epel)
perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch from dag has depsolving problems
–> Missing Dependency: perl(Digest::SHA1) is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: perl(LWP::Simple) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: perl(XML::LibXML) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch from dag has depsolving problems
–> Missing Dependency: perl(Digest::HMAC) is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: perl(DBD::Pg) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: perl(DBI) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: /usr/bin/ruby is needed by package munin-node-2.0.8-1.el5.noarch (epel)
munin-node-2.0.8-1.el5.noarch from epel has depsolving problems
–> Missing Dependency: perl(XML::Parser) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch from dag has depsolving problems
–> Missing Dependency: perl(Socket6) >= 0.19 is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
Error: Missing Dependency: perl(DBI) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: perl(XML::Parser) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: perl(XML::LibXML) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: perl(Socket6) >= 0.19 is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
Error: Missing Dependency: perl(LWP::Simple) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: perl(Digest::SHA1) is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
Error: Missing Dependency: perl(DBD::Pg) is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: /usr/bin/ruby is needed by package munin-node-2.0.8-1.el5.noarch (epel)
Error: Missing Dependency: perl(Digest::HMAC) is needed by package perl-Net-SNMP-5.2.0-1.2.el5.rf.noarch (dag)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Please someone help me out with installation of munin-node on this machine.

Thanks in advance :slight_smile: