Resolved - C preprocessor "/lib/cpp" fails sanity check


#1

I am having some difficulties installing nagios-3.1.1 on Fedora release 9 and would appreciate some assistance. I am attempting to follow the instructions in the quick start guide for Fedora.

After executing the command ‘./configure --with-command-group=nagcmd’ I receive the following error:

checking how to run the C preprocessor… /lib/cpp
configure: error: C preprocessor “/lib/cpp” fails sanity check
See `config.log’ for more details.

After searching and finding other similar error messages, I checked my installed pre-reqs / development / compiler packages and found:

httpd-2.2.8-3.i386
httpd-manual-2.2.8-3.i386
httpd-tools-2.2.8-3.i386
httpunit-1.6.2-1jpp.1.fc7.noarch

gcc-4.3.0-8.i386
gcc-c+±4.3.0-8.i386
gcc-gfortran-4.3.0-8.i386
gcc-java-4.3.0-8.i386

glibc-2.8-3.i686
glibc-common-2.8-3.i386
glibc-devel-2.8-3.i386

gd-2.0.35-5.fc9.i386
gd-devel-2.0.35-5.fc9.i386

cpp-4.3.0-8.i386

I believe I have the recommended packages installed, but maybe there is an update that I need.

FYI - uname -a:
Linux Fed9ns 2.6.25-14.fc9.i686 #1 SMP Thu May 1 06:28:41 EDT 2008 i686 athlon i386 GNU/Linux

I do not know as much about compiling from source as I would like to know and I am not familiar with what the output of config.log should look like. It appears to me that the ‘configure’ command is trying to determine how to compile the code by testing tools to see if they are available and using error messages, or lack thereof, to determine which tools are installed.

The problem occurs with both nagios-3.1.1 and nagios-3.0.6, so I am going to assume it the problem is in my environment. I believe this is the first time I have tried to compile from source on this machine.

Any thoughts or comments on how I can identify the source of my problem?

Thank you.


#2

and what does config.log say ? it says check for more details… :slight_smile:


#3

Thank you for your response. Below is contents of config.log. Sorry, it is about 25K.

As an aside, I am trying to locate sites where I can learn more about compiling from source.

contents of config.log follow:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.61. Invocation command line was

$ ./configure --with-command-group=nagcmd

---------

Platform.

---------

hostname = Fed9ns
uname -m = i686
uname -r = 2.6.25-14.fc9.i686
uname -s = Linux
uname -v = #1 SMP Thu May 1 06:28:41 EDT 2008

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/lib/qt-3.3/bin
PATH: /usr/kerberos/sbin
PATH: /usr/kerberos/bin
PATH: /usr/lib/ccache
PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /root/bin

-----------

Core tests.

-----------

configure:1810: checking for a BSD-compatible install
configure:1866: result: /usr/bin/install -c
configure:1885: checking build system type
configure:1903: result: i686-pc-linux-gnulibc1
configure:1925: checking host system type
configure:1940: result: i686-pc-linux-gnulibc1
configure:2011: checking for gcc
configure:2027: found /usr/lib/ccache/gcc
configure:2038: result: gcc
configure:2276: checking for C compiler version
configure:2283: gcc --version >&5
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)
Copyright © 2008 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2286: $? = 0
configure:2293: gcc -v >&5
Using built-in specs.
Target: i386-redhat-linux
Configured with: …/configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-cpu=generic --build=i386-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC)
configure:2296: $? = 0
configure:2303: gcc -V >&5
gcc: ‘-V’ option must have argument
configure:2306: $? = 1
configure:2329: checking for C compiler default output file name
configure:2356: gcc conftest.c >&5
configure:2359: $? = 0
configure:2397: result: a.out
configure:2414: checking whether the C compiler works
configure:2424: ./a.out
configure:2427: $? = 0
configure:2444: result: yes
configure:2451: checking whether we are cross compiling
configure:2453: result: no
configure:2456: checking for suffix of executables
configure:2463: gcc -o conftest conftest.c >&5
configure:2466: $? = 0
configure:2490: result:
configure:2496: checking for suffix of object files
configure:2522: gcc -c conftest.c >&5
configure:2525: $? = 0
configure:2548: result: o
configure:2552: checking whether we are using the GNU C compiler
configure:2581: gcc -c conftest.c >&5
configure:2587: $? = 0
configure:2604: result: yes
configure:2609: checking whether gcc accepts -g
configure:2639: gcc -c -g conftest.c >&5
configure:2645: $? = 0
configure:2744: result: yes
configure:2761: checking for gcc option to accept ISO C89
configure:2835: gcc -c -g -O2 conftest.c >&5
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before '’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf , struct stat , int), int, int);
| int argc;
| char **argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -qlanglvl=extc89 -c -g -O2 conftest.c >&5
gcc: unrecognized option '-qlanglvl=extc89’
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before '
’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf , struct stat , int), int, int);
| int argc;
| char **argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -qlanglvl=ansi -c -g -O2 conftest.c >&5
gcc: unrecognized option '-qlanglvl=ansi’
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before '
’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf *, struct stat *, int), int, int);
| int argc;
| char *argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -std -c -g -O2 conftest.c >&5
cc1: error: unrecognized command line option "-std"
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf , struct stat , int), int, int);
| int argc;
| char **argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -Ae -c -g -O2 conftest.c >&5
: error: missing ‘(’ after predicate
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before '
’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf , struct stat , int), int, int);
| int argc;
| char **argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -Aa -D_HPUX_SOURCE -c -g -O2 conftest.c >&5
: error: missing ‘(’ after predicate
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before '
’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf *, struct stat *, int), int, int);
| int argc;
| char **argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2835: gcc -Xc -D__EXTENSIONS
-c -g -O2 conftest.c >&5
gcc: unrecognized option '-Xc’
conftest.c:9:19: error: stdio.h: No such file or directory
conftest.c:10:23: error: sys/types.h: No such file or directory
conftest.c:11:22: error: sys/stat.h: No such file or directory
conftest.c:14: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before ‘’ token
conftest.c:48: error: expected declaration specifiers or ‘…’ before 'FILE’
configure:2841: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #include <stdarg.h>
| #include <stdio.h>
| #include <sys/types.h>
| #include <sys/stat.h>
| /
Most of the following tests are stolen from RCS 5.7’s src/conf.sh. */
| struct buf { int x; };
| FILE * (*rcsopen) (struct buf *, struct stat *, int);
| static char *e (p, i)
| char *p;
| int i;
| {
| return p
;
| }
| static char *f (char * (*g) (char **, int), char **p, …)
| {
| char s;
| va_list v;
| va_start (v,p);
| s = g (p, va_arg (v,int));
| va_end (v);
| return s;
| }
|
| /
OSF 4.0 Compaq cc is some sort of almost-ANSI by default. It has
| function prototypes and stuff, but not ‘\xHH’ hex character constants.
| These don’t provoke an error unfortunately, instead are silently treated
| as ‘x’. The following induces an error, until -std is added to get
| proper ANSI mode. Curiously ‘\x00’!=‘x’ always comes out true, for an
| array size at least. It’s necessary to write ‘\x00’==0 to get something
| that’s true only with -std. /
| int osf4_cc_array ‘\x00’ == 0 ? 1 : -1];
|
| /
IBM C 6 for AIX is almost-ANSI by default, but it replaces macro parameters
| inside strings and character constants. */
| #define FOO(x) ‘x’
| int xlc6_cc_array[FOO(a) == ‘x’ ? 1 : -1];
|
| int test (int i, double x);
| struct s1 {int (*f) (int a);};
| struct s2 {int (*f) (double a);};
| int pairnames (int, char **, FILE ()(struct buf *, struct stat *, int), int, int);
| int argc;
| char *argv;
| int
| main ()
| {
| return f (e, argv, 0) != argv[0] || f (e, argv, 1) != argv[1];
| ;
| return 0;
| }
configure:2867: result: unsupported
configure:2882: checking whether make sets $(MAKE)
configure:2903: result: yes
configure:2914: checking for strip
configure:2932: found /usr/bin/strip
configure:2945: result: /usr/bin/strip
configure:2960: checking how to run the C preprocessor
configure:3000: gcc -E conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3000: gcc -E conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3000: gcc -E -traditional-cpp conftest.c
conftest.c:11: error: assert.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3000: gcc -E -traditional-cpp conftest.c
conftest.c:11: error: assert.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3000: /lib/cpp conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3000: /lib/cpp conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3006: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3076: result: /lib/cpp
configure:3105: /lib/cpp conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3111: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. /
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3105: /lib/cpp conftest.c
In file included from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/syslimits.h:7,
from /usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:11,
from conftest.c:9:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/limits.h:122:61: error: limits.h: No such file or directory
configure:3111: $? = 1
configure: failed program was:
| /
confdefs.h. /
| #define PACKAGE_NAME “”
| #define PACKAGE_TARNAME “”
| #define PACKAGE_VERSION “”
| #define PACKAGE_STRING “”
| #define PACKAGE_BUGREPORT “”
| /
end confdefs.h. */
| #ifdef STDC
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3173: error: C preprocessor “/lib/cpp” fails sanity check
See `config.log’ for more details.

----------------

Cache variables.

----------------

ac_cv_build=i686-pc-linux-gnulibc1
ac_cv_c_compiler_gnu=yes
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnulibc1
ac_cv_objext=o
ac_cv_path_STRIP=/usr/bin/strip
ac_cv_path_install=’/usr/bin/install -c’
ac_cv_prog_CPP=/lib/cpp
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_cc_c89=no
ac_cv_prog_cc_g=yes
ac_cv_prog_make_make_set=yes

-----------------

Output variables.

-----------------

BASEEXTRALIBS=’‘
BROKERLIBS=’‘
BROKER_H=’‘
BROKER_LDFLAGS=’‘
BROKER_O=’‘
CC=‘gcc’
CFLAGS=’-g -O2’
CGIEXTRAS=’‘
CHECKRESULTDIR=’‘
COMMAND_OPTS=’‘
CPP=’/lib/cpp’
CPPFLAGS=’‘
DEFS=’‘
ECHO_C=’‘
ECHO_N=’-n’
ECHO_T=’‘
EGREP=’‘
EXEEXT=’‘
GDLIBS=’‘
GREP=’‘
HTTPD_CONF=’‘
INITDIR=’‘
INSTALL=’/usr/bin/install -c’
INSTALLPERLSTUFF=’‘
INSTALL_DATA=’${INSTALL} -m 644’
INSTALL_OPTS=’‘
INSTALL_PROGRAM=’${INSTALL}‘
INSTALL_SCRIPT=’${INSTALL}‘
LDFLAGS=’‘
LIBOBJS=’‘
LIBS=’‘
LTLIBOBJS=’‘
MAIL_PROG=’‘
MOD_CFLAGS=’‘
MOD_LDFLAGS=’‘
OBJEXT=‘o’
PACKAGE_BUGREPORT=’‘
PACKAGE_NAME=’‘
PACKAGE_STRING=’‘
PACKAGE_TARNAME=’‘
PACKAGE_VERSION=’‘
PACKDIR=’‘
PATH_SEPARATOR=’:‘
PATH_TO_TRACEROUTE=’‘
PERL=’‘
PERLDIR=’‘
PERLLIBS=’‘
PERLXSI_O=’‘
SET_MAKE=’‘
SHELL=’/bin/sh’
SNPRINTF_O=’‘
SOCKETLIBS=’‘
STRIP=’/usr/bin/strip’
THREADLIBS=’‘
TMPDIR=’‘
USE_EVENTBROKER=’‘
VERSION=’‘
XCDC=’‘
XCDH=’‘
XDDC=’‘
XDDH=’‘
XODC=’‘
XODH=’‘
XPDC=’‘
XPDH=’‘
XRDC=’‘
XRDH=’‘
XSDC=’‘
XSDH=’‘
ac_ct_CC=‘gcc’
bindir=’${exec_prefix}/bin’
build=‘i686-pc-linux-gnulibc1’
build_alias=’‘
build_cpu=‘i686’
build_os=‘linux-gnulibc1’
build_vendor=‘pc’
cgiurl=’‘
command_grp=’‘
command_user=’‘
datadir=’${datarootdir}‘
datarootdir=’${prefix}/share’
docdir=’${datarootdir}/doc/${PACKAGE}‘
dvidir=’${docdir}‘
exec_prefix=‘NONE’
host=‘i686-pc-linux-gnulibc1’
host_alias=’‘
host_cpu=‘i686’
host_os=‘linux-gnulibc1’
host_vendor=‘pc’
htmldir=’${docdir}‘
htmurl=’‘
includedir=’${prefix}/include’
infodir=’${datarootdir}/info’
init_dir=’‘
libdir=’${exec_prefix}/lib’
libexecdir=’${exec_prefix}/libexec’
localedir=’${datarootdir}/locale’
localstatedir=’${prefix}/var’
lockfile=’‘
mandir=’${datarootdir}/man’
nagios_grp=’‘
nagios_name=’‘
nagios_user=’‘
nagiostats_name=’‘
oldincludedir=’/usr/include’
pdfdir=’${docdir}‘
prefix=‘NONE’
program_transform_name=‘s,x,x,‘
psdir=’${docdir}‘
sbindir=’${exec_prefix}/sbin’
sharedstatedir=’${prefix}/com’
subdirs=’‘
sysconfdir=’${prefix}/etc’
target_alias=’’

-----------

confdefs.h.

-----------

#define PACKAGE_NAME “”
#define PACKAGE_TARNAME “”
#define PACKAGE_VERSION “”
#define PACKAGE_STRING “”
#define PACKAGE_BUGREPORT “”

configure: exit 1*******


#4

I may have found my problem. It appears that I do not have glibc-headers installed.

now to find the dvd…

more later.


#5

use yum to update your system and istall missing packages :slight_smile:


#6

The problem was the missing glibc-headers package. Once the package was installed I was able to proceed with the steps in the Quick Start Guide. I moved forward to Step 5, Configure the Web Interface without a problem, and am in the process of making sure Apache is running, etc.

Thanks for the recommendation for installing the package with yum. Fortunately, I had the glibc-headers rpm from my install DVD handy. It installed without a problem. I was hesitant to use yum due to my lack of knowledge about it mainly that it would spend quite a bit of time updating numerous packages - pre-reqs and co-reqs. and I may need to know the exact mane of the package desired. I’m trying to be a careful noob.

Hard to believe, but I did look at the config.log for quite a while trying to determine what it was trying to tell me.

Thanks again for your help. I’ll edit the subject line to indicate this is now resolved.


#7

Glad you got it to work
Using yum (or other package managers like aptitude for Debian) helps keeping th ewhole system updated. If the systme is exposed to the internet soriously consider using it as it helps to install all security pathches as they become available (nagios packages may be a version or two behind… so keep this in mind). :slight_smile: