Same result in different cfg file



I’ve installed and configured nagios in centos5.5
i can able to log in web

I have 5 linux Server running and UP
I want to monitor this 5 linux server i installed in 1 linux server so 4 linux are not yet monitored
what i did in nagios.cfg is to add new line

Definitions for monitoring the local (Linux) host

cfg_file=/usr/local/nagios/etc/objects/localhost.cfg <----- 1 linux server


on the objects path i copied the localhost.cfg in server1.cfg
i modified the hostname and group_host

define host{
use linux-server ; Name of host template$
; This host definition $
; in (or inherited by) $
alias Server2


define hostgroup{
hostgroup_name linux-servers2 ; The name of the hostgroup
alias Server2 ; Long name of the group
members ; Comma separated list of hosts that$

when i run the command to confirm theres no error

now what ive noticed is that
the result from localhost.cfg is the same in server2.cfg which i modified some codes

such as:
current load
Current users

please anyhelp is highly appreciated.



partition space, load and users at least are LOCAL CHECKS. so they will always return the result from the local system.


Thanks for your reply.

Yes i reboot the system on/off but still same result
now i have windows its ok but for linux i have 3 hostname
one is the localhost others is different machine name which i used first the IP address.

please help



the on/off part is my signature… you shouldn’t take that too literally :stuck_out_tongue:
anyway as the checks are executed locally it will not help much to restart the system.

you need to run those checks on the remote hosts, for disk space and server load you can use snmp checks, try searching the forums, i’m quite sure this has already been discussed.