Service won't display


#1

I have a check_nt USEDDISKSPACE service that will not appear for one of my hosts (HHVS1). It shows up for all the other hosts. I even tried creating a separate service definition for the problem host and it will still not display in Nagios. All my other cfg updates display in Nagios. Here is the service definition:

define service{
use generic-service
hostgroup_name windows-servers
host_name !HHAPSRV01, !BACKUP
service definition D:\ Drive Space
check_command check_nt!USEDDISKSPACE! -l d -w 80 -c 90
notification_options c,r
}

It works exactly as expected with all my other hosts. The missing service’s host, HHVS1, is part of windows_servers group. It is the only one in the windows-servers group that does not display the service. As expected, HHVS1 does display other services due to being a part of windows-servers hostgroup.

Originally, the HHVS1 host was excluded from this service, but I removed the bypass (!HHVS1) from the host_name field, restarted nagios and it still will not display. All the other services for HHVS1 display, even a USEDDISKSPACE for the C drive.

When I issue check_nt from the command line, it reports the D drive info just fine.

Any ideas on how I can make this service display for HHVS1 or how to troubleshoot this?


#2

Solved.

Shutdown Nagios. Deleted objects.cache file in /usr/local/nagios/var. Started Nagios.