Set hosts.cfg with 3 servers.But only the local server is be


#1

Hi all,

I’ve set my Nagios exactly as explained in ubuntuforums.org/showthread.php?t=223498 and no prob at all.
I’ve set all cfg files in order to monitor PING for 1 servers.

But when I open Nagios only 5 services to the local host is showed. Where all the .cfg settings are gone? (see screenshot attached)
All the .cfg files are located in /etc/nagios and also (just in case) in /etc/nagios/etc

Here some reports:

**[email protected]:~# /etc/nagios/bin/nagios -v /etc/nagios/etc/nagios.cfg

Nagios 2.10
Copyright © 1999-2007 Ethan Galstad (nagios.org)
Last Modified: 10-21-2007
License: GPL

Reading configuration data…

Running pre-flight check on configuration data…

Checking services…
Checked 5 services.
Checking hosts…
Checked 1 hosts.
Checking host groups…
Checked 1 host groups.
Checking service groups…
Checked 0 service groups.
Checking contacts…
Checked 1 contacts.
Checking contact groups…
Checked 1 contact groups.
Checking service escalations…
Checked 0 service escalations.
Checking service dependencies…
Checked 0 service dependencies.
Checking host escalations…
Checked 0 host escalations.
Checking host dependencies…
Checked 0 host dependencies.
Checking commands…
Checked 22 commands.
Checking time periods…
Checked 4 time periods.
Checking extended host info definitions…
Checked 0 extended host info definitions.
Checking extended service info definitions…
Checked 0 extended service info definitions.
Checking for circular paths between hosts…
Checking for circular host and service dependencies…
Checking global event handlers…
Checking obsessive compulsive processor commands…
Checking misc settings…

Total Warnings: 0
Total Errors: 0

Things look okay - No serious problems were detected during the pre-flight check
**
My hosts.cfg file is

[email protected]:/etc/nagios/etc# cat hosts.cfg
define {
name generic-host;
notifications_enabled 1;
event_handler_enabled 1;
flap_detection_enabled 1;
process_perf_data 1;
retain_status_information 1;
retain_nonstatus_information 1;
register 0;
}
define host{
use generic-host
host_name venus.funnydomain.com
alias DB Server
address 10.230.10.121
check_command check-host-alive
contact_groups UNIX
max_check_attempts 10
notification_interval 120
notification_period 24x7
notification_options d,u,r
}

Also my servicegroups.cfg is:

[email protected]:/etc/nagios/etc# cat servicegroups.cfg
define servicegroup {
servicegroup_name pingservices
alias PING Servers
members venus.funnydomain.com,Ping Service
}

Becasue there is nothing in “How to” about modifying the file /etc/nagios/etc/nagios.cfg, I didn’t changed it. But should I?

Thanks for your help in advance!!

BTW, I unstalled and installed Nagios 4 times and always the same prob.


#2

Screenshot attached here.


#3

Where? :wink:


#4

.


#5

Definetively something is wrong somewhere, for any reason the file is not being attached…amazing! Hopefully it works now !!

If not, can you please give me some advice anyway?