Shut up Nagios


#1

Hi, I’m currently testing a nagios system with about 300 hosts and services and it’s generating a lot of notifications which I’d rather not receive by mail for now.

I’ve tried the following:

  • Create a never notification schedule and set it up for all services and hosts
  • Disabled notification in nagios.cfg
  • Disabled notification in the service and host template
  • Changed the mail address to a bogus one
  • Reload / Force-reload with each change
  • Deleted objects.cache

And it still is spamming my inbox… :shock:

When I check the configuration of Nagios in the web console everything looks fine. Nagios has accepted my setting but it just keeps notifying me.


#2

“/etc/init.d/nagios stop”, wait two minutes, “ps -ef | grep nagios”,
kill all surviving processes and start nagios again. you possibly have two instances of nagios running…

Luca


#3

Changing some entries in the config files, have no affect, unless you have state retention off. YOu should use the web interface to turn off notifications, since nagios has “memorized” your previous settings.

Clik on the host/service that you don’t want notifications from, and then clik on the “disable notifications” link. YOu may have to “enable” then “disable”. But now that you have done that, you will not get any notifications from that service.

For an explanation as to why, see the docs.
nagios.sourceforge.net/docs/1_0/ … tion_notes