SNMP monitoring zywall 70


#1

SNMP newbee question

I want to start monitoring my Zywall 70 router / vpn builder with check_snmp
The zywall has its own mib file. Where must i place the mib file on the nagios server ?

The main things i want to monitor are the cpu utilization and how many VPN’s are up
For the cpu is the oid .1.3.6.1.4.1.890.1.6.1.1.1 “Show device CPU load in %, it’s the snapshot of CPU load when
getting the values.”

But when i enter this command
/usr/lib/nagios/plugins/check_snmp -H xx.xx.xx.xx -C public .1.3.6.1.4.1.890.1.6.1.1.1

I get this error
SNMP problem - No data received from host
CMD: /usr/bin/snmpget -t 1 -r 5 -m ‘’ -v 1 [authpriv] xx.xx.xx.xx:161

i gues it has to do with the missing mib file


#2

Let’s first check the obvious. Does the following return anything?

or

(assuming 10.15.36.40 is the IP of your ZyWall)


#3

Both commands return this output

SNMPv2-MIB::sysDescr.0 = STRING: ZyWALL 70
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.890.1.6
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (714770600) 82 days, 17:28:26.00
SNMPv2-MIB::sysContact.0 = STRING:
SNMPv2-MIB::sysName.0 = STRING: MyZyWall70
SNMPv2-MIB::sysLocation.0 = STRING:
SNMPv2-MIB::sysServices.0 = INTEGER: 14


#4

Good! 8)

Have you tried adding a SNMP version setting?


#5

I didn’t but now i tried :mrgreen:
Unfortunately the same problem.

SNMP problem - No data received from host
CMD: /usr/bin/snmpget -t 1 -r 5 -m ‘’ -v 2c [authpriv] xx.xx.xx.xx:161


#6

I think I found the reason. And a possible fix…

For some reason in the plugin… the default value for the miblist is commented out. Effectively the -m parameter ends up with a ‘’ instead of ‘ALL’.

the quick fix is to hand-edit the check_snmp.c file in the nagios-plugins-1.4.11/plugins folder and change this line:

to this:

& remake/reinstall it.
That should be on line 178.

Does anyone know why it was left commented out?

Alternatively… you can specify the “-m” parameter & put “ALL” in there if required.