Starting Nagios problem


#1

hi
my preflight is working fine but when i try start nagios i get the following

[root@linux init.d]# service nagios start
Starting network monitor: nagios
su: incorrect password

can any one help
?


#2

or if i use a different command prompt i get the following

root@linux init.d]# nagios start

Nagios 1.0
Copyright © 1999-2002 Ethan Galstad (nagios@nagios.org)
Last Modified: 11-24-2002
License: GPL

Error: Cannot open main configuration file ‘/etc/rc.d/init.d/start’ for reading!
Nagios 1.0 starting… (PID=22700)
Bailing out due to one or more errors encountered in the configuration
files. Run Nagios from the command line with the -v option to verify
your config before restarting. (PID=22700)


#3

[quote=“glynner”]or if i use a different command prompt i get the following

root@linux init.d]# nagios start

Nagios 1.0
Copyright © 1999-2002 Ethan Galstad (nagios@nagios.org)
Last Modified: 11-24-2002
License: GPL

Error: Cannot open main configuration file ‘/etc/rc.d/init.d/start’ for reading!
Nagios 1.0 starting… (PID=22700)
Bailing out due to one or more errors encountered in the configuration
files. Run Nagios from the command line with the -v option to verify
your config before restarting. (PID=22700)
[/quote]

Executing “nagios start” from the command line and getting some output idicates that you have “nagios” in roots path. Verify this with "which nagios"
So, since the binary “nagios” is in your path, executing “nagios start” means execute nagios with the options “start” and for nagios, this means use the config file called “start”. Since you are in the directory /etc/rc.d/init.d nagios assumes that is where the config file is located.

Now, if you want to actually execute the init script named nagios, then do this:
cd /etc/rc.d/init.d
./nagios start