Status Map not displaying Hosts/Icons


#1

Hi,

I hope that this is the right forum, and that someone can help.

I cannot get the statusmap.cgi to work in Nagios. I have searched the web, installed what i think I need and still no luck. When I load the statusmap.cgi I get a page with the usual headers and information, but no map. I get different results when I look at the webpage, depending on whether I select ‘User-supplied coords’ or Circular. When I look at the source for the webpage I get this:

This shows that there is an image, but there are no hosts/icons on this image, it is blank. Additionally if I look at the ‘circular’ option I get the following error message:

“You have not supplied any host drawing coordinates, so you cannot use this layout method.”

Unfortunately I have included the coords in the hostextinfo.cfg file.

So I am unsure why no icons/hosts are being drawn. I have compiled NAGIOS with all the relevant options (I think), and added all the relevant libraries. Additionally the statusmap.cgi page wont display the hosts even if I use GIFs or JPEGs. I am lost!! If anyone can help I would be very grateful.

In the event I cannot get this to work, can anyone suggest any other tools/apps I can use for generating the statusmap?

Some information regarding my installation

System: Fedora Core 5
Nagios: 2.5
GCLibc: 2.4-4 (glibc, glibc-common, glibc-devel, glibc-headers, glibc-kernheaders)
GD Library
libpng
libiconv-1.9.2

Output from 'ldd statusmap.cgi’
linux-gate.so.1 => (0x0031a000)
libgd.so.1.8 => /usr/lib/libgd.so.1.8 (0x0098e000)
libz.so.1 => /usr/lib/libz.so.1 (0x0093d000)
libm.so.6 => /lib/libm.so.6 (0x00916000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00c9b000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x0064d000)
libc.so.6 => /lib/libc.so.6 (0x007db000)
libXpm.so.4 => /usr/lib/libXpm.so.4 (0x0097b000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00a72000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00c31000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00bb1000)
/lib/ld-linux.so.2 (0x007be000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00976000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00a6a000)
libdl.so.2 => /lib/libdl.so.2 (0x00910000)
libexpat.so.0 => /lib/libexpat.so.0 (0x00b83000)

(Note, it looks like linux-gate.so.1 and /lib/ld-linux.so.2 may not be necessary, but correct me if i am wrong)

Section from /usr/local/nagios/etc/hostextinfo.cfg

define hostextinfo{
host_name server1
notes This is the primary Netware file server
notes_url webserver.localhost.localdomain/ … t=netware1
icon_image redhat.png
icon_image_alt RedHat 7.2
vrml_image novell40.png
statusmap_image redhat.gif
2d_coords 100,250
3d_coords 100.0,50.0,75.0
}

I am now at a loss to know what is wrong. Please can someone help.

Best Regards,

Michael.


#2

see other forum. I made a reply there.


#3

jakkedup wrote:

“nagios.cfg should contain the location of /usr/local/nagios/etc/hostextinfo.cfg
It sounds to me, that you have that line commented out, or you have incorrect permissions on that file, and nagios user can read it.
Once you correct the problem, you will have to reload nagios.
Also, it sounds like you have incorrect permissions for apache to read your image files.
ls -la /usr/local/nagios/share/images/logos/”

Thanks for the reply jakkedup. All the things you have mentioned are already done, and I have installed libicon-1.9.2.tar.gz as well. I have put a space between hostextinfo and the {, but still no luck.

I am feeling either I am missing something simple (I cant think what) or that it simply doesnt work on FC5. The StatusMap is one of the things I wanted with Nagios so I am now wondering wether I need to downgrade to FC4 (a lot of effort, the server already runs other apps), or finding another monitoring product.

If anyone has anymore help on this one I would really appreciate it.

Cheers,

D.


#4

again, I replied in other forum.