Statusmap.cgi: The statusmap, trends and histogram CGIs are


#1

I cannot view the page when i click on the Status Map link in the menu.

From what I can see, that link calls the statusmap.cgi file which is missing from versions 1.2 & 2.0b2, co’s I have checked there first also.

Any more ideas please? :frowning:
Edited ]


#2

Anything constructive will do :stuck_out_tongue:


#3

it has to be a configure or compiler error.

Luca


#4

[quote=“luca”]it has to be a configure or compiler error.

Luca
[/quote]

Couldn’t you just send me the statusmap.cgi file? Will it work then?..
Or what would stop that particular file from compiling?.. :?


#5

missing GD libraries? and it probably wouldn’t work because you need the same paths for all libs (and the same OS)

Luca


#6

#7

But the statusmap.cgi file does not exist anywhere thou. Or does that get created if it does find that GD is installed. Co’s I have been installing the GD Libraries. (I might be doing something wrong there)


#8

check if configure gives any warnings about the GD libraries.
If configure doesn’t find GD libs the graphic cgis are not compiled, that’s why you don’t find them.

Luca


#9

Again, start from the beginning and report to us what configure complains about. The reason there is no statusmap.cgi file is due to it never being created in the first place. The reason it was created could be due to a few things. One, like I pointed out, you may have run ./configure --disable-statusmap, or the other, it couldn’t find the cd library. If the latter, then you can tell configure where they are with the switch --with-gd-libe= and the --with-gd-inc= switches.


#10

U have to got gd lib installed on ur os…
gd lib needs libjpeg, libpng and ziplib. When u’ll be sure to have them installed in \usr\lib or any other folder.
Run the configure of the GD lib and check if at the end it shows u that all the needed libs are well supported.
It should show soemthin like
jpeg yes
png yes

zlib yes…

note : u can run the configure by including libs directories :
./configure ‘–with-jpeg=/usr/local’ ‘–with-png=/usr/local’ ‘–with-zlib-dir=/usr/local’

If get any “no” it’s that somethin’s goin wrong before.
Once done with that go into ur nagios setup dir tape make clean and retry the nagios configure and make.
If the compilation still break up after building statusmap.cgi modify the statusmap.c file by putting 2 lines in comments (// or /* */) :

else if(!strcasecmp(ext,".jpg") || !strcasecmp(ext,".jpeg"))
im=gdImageCreateFromJpeg(fp);

Re-run the make clean , configure and make then u should have statusmap.cgi and trends.cgi well added in ur nagios cgi dir.

Hope this will help. :shock:


#11

Thanks sir_dlb I have tried all that and now get


#12

Does trend link work or not ?
Are you sure u’ve got no errors before the make clean (gdlib installation) ?
Did the nagios make all return any errors ?
Instead of copying the web errors u should show us compilation ones :wink:


#13

Ok - I’ll do it all again. Thanks


#14

Finally resolved this issue. After installing and compiling libjpeg via command line - there seemed to be a conflict somewhere which I resolved by downgrading a number of libs via the yast installer.


#15

hi cagen it’s look like i have the same problem with nagios , missing some cgi file : statusmap, hstogram and trends. can anyone tell me the solution to the problem , thanks


#16

check the “configure” command output, usually it tells all you need :slight_smile:

Luca


#17

Thanks Cagen for informing us how you fixed this. I’m sure it will help someone else too.


#18

I also have the same problem
Red Hat 9.0
installed all the lib packages
for some reason when I run ./configure it can’t find the GD libs, even if I explicitly specify the dir /usr/lib
I had no problems getting this to work with RH 7.3
I can complie the GD lib with no problems, all works fine.
so why does the test for GD not work?

the rest of Nagios runs fine.


#19

edit the /etc/ld.so.conf file and make sure the lib directory where gd is installed is in that file, i.e. /usr/lib perhaps. Then run ldconfig.
Now try to ./configure again.


#20

I believe you need the development versions of gd, libpng, and libjpeg installed as well. I had these same problems until I installed the development version, did a make clean, and did a reconfigure.