Unable to boot *gcov* enabled kernel on KVM guest




  • I have RPMs build with CONFIG_DEBUG_FS=y CONFIG_GCOV_KERNEL=y.
  • I have lustre RPMs with appropriate CFLAGS and LDFLAGS
  • but when I boot this kernel on KVM guest I am getting PANIC (I can attach the console logs)

kernel panic attempted to kill init !

I tried

  • Increasing the guest memory
  • disabling selinux, acpi=off
  • re-creating initrd image, OR using the earlier working initrd image
  • “stripping down” kernel image size

but nothing seems to help.

  • please note, the kernels with out gcov support boot w/o any issues
  • patch-less kernels work
  • I have collected the serial_console logs. I can attach those here.

“The interesting part is the same RPMs are installed on VBOX or Vmware guests w/o any issues but not on KVM guest”

  • Details about the KVM

virsh version
Compiled against library: libvirt 0.10.2
Using library: libvirt 0.10.2
Using API: QEMU 0.10.2
Running hypervisor: QEMU 0.12.1

Sorry to cross post, i had posted this on ltp-coverage@sourceforge. But I am still stuck with the issue.
Let me know, if you I should post more info or anything that should be tried.
Appreciate your time.

Thanks in advance



  • messages like
    dracut: Mounted root filesystem /dev/vda1
    dracut: Switching root

are seen so problem is not in initrd I assume.

  • The PANIC is seen after that.
  • I am doubting there is memory leak or overflow due to enabling gcov. Looking to check that statically. I am not sure if its the right way but as of now attempting that.

If there are any suggestions or pointers please share.

Appreciate your time.