Uncomment in nagios.cfg error


#1

Hello there

the quick instruction on how to install of nagios was great and very easy
but the problem is when i uncomment this # sysmbol to nagios.cfg
because i wnt to monitor the windows…

it got an error like this “Ooopppsss”

please anyone can guide me…

thanks you


#2

Hi,
I do not understand which parameter you are uncommenting.

When starting (or trying to start) the nagios daemon, it says in which file you’ll find details about the error encountered, did you check it out?

Bye
Ivan


#3

heres the parameter #cfg_file=usr/local/nagios/etc/objects/windows.cfg
once i remove the comment symbol then i restart the nagios and my apache…

it gives me an error like this

Whoops!
Error: Could not read host and service status information!

I dont know the problem but I already installed on my machine the nsclient…

Please help me…

thank you…


#4

heres the parameter #cfg_file=usr/local/nagios/etc/objects/windows.cfg
once i remove the comment symbol then i restart the nagios and my apache…

it gives me an error like this

Whoops!
Error: Could not read host and service status information!

I dont know the problem but I already installed on my machine the nsclient…

Please help me…

thank you…
cheesewizz


#5

I use this -v to verify my nagios but it shows me like this once i type it in the terminal

The program ‘nagios’ can be found in the following packages;
*nagios-text
*nagios-pgsql
*nagios-mysql

try: apt-get install
make sure you have hte ‘universe’ component enabled
-bash: nagios: command not found

if i install all that the nagios get me an error
i cant browse nagios once i install that…

please need help to guide me i want to use nagios to monitor all my pc…

thank you


#6

From what I can see you are missing the leading / in the path to your windows.cfg file.

Your entry shows:
#cfg_file=usr/local/nagios/etc/objects/windows.cfg

When infact it should be:
#cfg_file=/usr/local/nagios/etc/objects/windows.cfg

Note the extra / before usr

This should solve your problem I hope.

Cheers
Leigh


#7

oooppps sorry i forgot to put it…
But the parameters in the nagios.cfg the symbol of this / was included…

still error…


#8

Is there actually a windows.cfg file in that directory?