use_authentication=0 no use


I have install naios 3.06 , and the web interface is OK . I do not want an authentication before login , so I change “use_authentication=0” in cgi.cfg file . But when I restart apache and nagios , it take no use .

Then I add a line to nagios.cfg ,
when I restart nagios , that happens errors .

$ sudo /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios 3.0.6
Copyright © 1999-2008 Ethan Galstad (
Last Modified: 12-01-2008
License: GPL

Reading configuration data…

Error: Unexpected token or statement in file ‘/usr/local/nagios/etc/cgi.cfg’ on line 15.

***> One or more problems was encountered while processing the config files…

 Check your configuration file(s) to ensure that they contain valid
 directives and data defintions.  If you are upgrading from a previous
 version of Nagios, you should be aware that some variables/definitions
 may have been removed or modified in this version.  Make sure to read
 the HTML documentation regarding the config files, as well as the
 'Whats New' section to find out what has changed.

the line 15 of ‘/usr/local/nagios/etc/cgi.cfg’ file is not null , when I uncommet this line , "sudo /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg " told me next line the same error .

What should I to do ?

Thanks for yours notice .


Did I missing something ?



This is not required - the cfg_file and cfg_dir variables are only for configuration files relating to object definitions (i.e. host objects, service objects etc).
Sorry but I am not certain as to why use_authentication=0 has not worked for you… perhaps there is a cacheing issue?