VNC black screen for non-root users!


#1

Hey!

Situation

I’m trying to set up vnc to work between my Fedora Core 3 box to my windows XP machine, I wish to use the linux box as a headless server with vnc remote access to the internet (NOT ROOT) =) I’m trying to use tight vnc to connect from the XP machine to the Xvnc server on the redhat machine. Redhat vnc package was pre-installed!

Problem

My XP machine can get a connection to the Xvnc server with all users, however only root gets a gui, any other user gets a black screen with a cross for the cursor! This isn’t very helpful as you can imagine and allowing a root access to the internet is not an option!

thanks for any help!


#2

Hi,

The only way to get your VNC client application working again is to start a Remote Desktop Connection (or Remote Desktops if you have W2K3 server admin tools) to the Windows XP system, open a DOS prompt and type:

TSCON 0 /DEST:console

Your RDC connection will close, (the session will stay opened), and you’ll be able to use VNC again.
:stuck_out_tongue:


#3

[quote=“jeff^l”]Problem

My XP machine can get a connection to the Xvnc server with all users, however only root gets a gui, any other user gets a black screen with a cross for the cursor! This isn’t very helpful as you can imagine and allowing a root access to the internet is not an option!

thanks for any help![/quote]

Do you have a xstartup file in the .vnc folders of the various non-root users?
Mine contains:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
unset SESSION_MANAGER
gnome-session &

This starts the window manager for me.