Vsftpd pasv problems


#1

Hi all,

I’ve congfigured vsftpd to be a remote private server for use on and off my campus. Basically I have it set up to require a password login to an account, and be able to upload/download files as I wish. This all works fine, but in order to use the ftp server, I need to disable passiveFTP on my browser before I can use view the files on the account. Is there some way around this, so I don’t have to deselect Passive FTP on my browser?

I also have a problem when using OS X Tiger’s Safari to view the ftp server. I can login to my account and view files, but I am unable to upload any and downloading seems to work OK.

Here’s my vsftpd.conf file

anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
data_connection_timeout=120
ls_recurse_enable=YES
chroot_local_user=YES
ftp_data_port=20
listen=YES
log_ftp_protocol=YES
pasv_enable=YES
pasv_min_port=2021
pasv_max_port=2025
pasv_promiscuous=YES

I also have a broadband router that is forwarding ports 20 and 2021 to 2025 to my server.

Thanks in advance for the help.


#2

Okay, so my fault, the changes I made to the vsftpd.conf file seem to make it work with Passive FTP enabled.

The OS X problem is still there though. However I don’t actually believe that safari is the program to blame. It may be another setting in the mac OS X, or still the vsftpd.conf file.

Sorry for the mix-up.