Vsftpd (with ssl) connects but throws error on ls/get/put


I am trying to run vsftpd on my arm based linux board. I cross compiled the vsftpd and executed, I was able to connect, get list, get-put file etc. Now I started enabling SSL support in vsftpd. I enabled and cross compiled properly. I create a SSL certificate as instructed in “http://www.cyberciti.biz/tips/configure-vsfptd-secure-connections-via-ssl-tls.html” and started the vsftpd. When I tried to connect to server, I was able to connect but as I try to view the directory structure (ls command) or get put, it throws error as closed the connection as:

ftp> ls 200 PORT command successful. Consider using PASV. 150 Here comes the directory listing. ftp: SSL_connect DATA error -1 - error:1408E0F4:SSL routines:SSL3_GET_MESSAGE:unexpected message ssl_getc: SSL_read failed -1 = 0 421 Service not available, remote server has closed connection

My vsftpd.conf file includes the ssl settings as suggested in the above link:

ssl_enable=YES allow_anon_ssl=YES (I tried NO also, but no help) force_local_data_ssl=YES force_local_logins_ssl=YES ssl_tlsv1=YES ssl_sslv2=NO ssl_sslv3=NO rsa_cert_file=/etc/vsftpd/vsftpd.pem

Can anybody help me to figure out what’s the issue here?