Warning threshold must be float or float triplet!


#1

Hello
I am still having probs getting nrpe work.no i am getting the err Warning threshold must be float or float triplet!
when i run the check_load frm my nagios server for remote host.
i read docs abt it.Also changes in check_load.c

add the Line "setlocale(LC_NUMERIC, “POSIX”);"
in plugins/check_load.c

  • ./configure --disable-nls

But still the same err i am getting.
the check_load plugin individually is wrkng fine on remote and nagios host.
Can nebody help me out with this.
Thanks


#2

hello there
can any one help me out with it.
As this err i am getting with other plugins on that server.
when i do ./check_nrpe -H serverip -p 5666

i get NRPE V.2.0

But when i give ./check_nrpe -H serverip -p 5666 -c check_load
i get warning threshold must be float or float triplet!

has any one come across this err


#3

If I’m not mistaken, check_load has option values. type check_load --help to find out what they are.


#4

hello
I tried with arguments also but still i am getting the same error.Is there anything you can suggest me.

Thanks


#5

What’s your entry for check load in the nrpe.cfg on the remote machine. Should be something like.
command[check_load]=/usr/local/lib/nagios/plugins/check_load -w 15,10,5 -c 30,25,20


#6

Ya this is the entry for check_load in nrpe.cfg on remte machine.


#7

Are you sure that the path in your nrpe.cfg is to the version that you recompiled? It doesn’t make any sense that the plugin works correctly when you call it from the command line on the remote host but fails when you use nrpe. Try running exactly what you have in the nrpe.cfg and see if it works.


#8

hello redtom
yes i am very sure abt this.
I have nrpe2.0 installed on my nagios server and remote host.
also i have installed nagios-plugins 1.4 on both the servers.

from my nagios server when i run this command
./check_nrpe -H remotehostaddress
i get NRPEV2.0
when i run ./check_nrpe -H remotehostaddress -p 5666
i get NRPEV2.0

now hen i try executing plugin

./check_nrpe -H remotehostaddress -p 5666 -c check_load
i get Warning threshold must be float or float triplet!

Also when i just run the plugin from my remote host i get correct output
./check_load -w 15,10,5 -c 30,25,20

OK - load average: 0.05, 0.13, 0.12|load1=0.050000;15.000000;30.000000;0.000000 load5=0.130000;10.000000;25.000000;0.000000 load15=0.120000;5.000000;20.000000;0.000000

But with nrpe i get the warning threshold err.
Also i have added the entry in hosts.allow.
Also checked my nrpe.cfg
couldnt get exactly where i am going wrong.

Thanks for ur help


#9

Hi
Also when i checked /var/log/messages
i got there and err
Network server bind failure

wht can be done


#10

Check your nrpe.cfg From one of your previous quereys you had two entries for check_load. Make sure you hash out the one that you don’t need. If it still doesn’t work then post your nrpe.cfg again.


#11

hey Thanks
i got the problem and solved.
your help was really appreaciable.
Thanks again


#12

hey Hi there…
Now again difrenet prob started .my openssl version is same on both the servers also i have installed with ssl version still i am getting
CHECK_NRPE: Error - Could not complete SSL handshake

Let me know if any one has solution for this
Thanks
Aparna


#13

Aparna

  1. You should open a new message for each query - otherwise it makes it hard for people to help.
  2. Have you checked the docs and faqs first. Look at this entry and work through all of the items first.
    nagios.org/faqs/viewfaq.php?faq_id=191

#14

Does anybody know what Aparna did to fix his Current Load - Warning threshold must be float or float triplet! error?

I read through his post and though yep that is my problem and then he fixes it but never gave the solution.

Any ideas ? I have followed the previous instructions.


#15

[quote=“Aparna”]hey Thanks
i got the problem and solved.
your help was really appreaciable.
Thanks again[/quote]

Hi Aparna,

May i know how did you solved this problem.
I am still having the same problem "Warning threshold must be float or float triplet!"
That is showing on my Nagios Monitoring console. But i have only one entry for check_load.

Thanks in Advance,
Nagaraj G