Web interface 500 error


#1

WHM 11.28.35
CENTOS 5.5 i686 standard on ns1

I am at my home computer and trying to connect to my server web interface which I have nagios installed on.

I followed these quickstart installation instructions here:
nagios.sourceforge.net/docs/3_0/ … edora.html

When going to the web interface link the login box pops up and I enter the username and password then I get the 500 error.

I got zero errors when running this command:
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Apparently you cannot directly edit httpd.conf file anymore.
pico /usr/local/apache/conf/httpd.conf

DO NOT EDIT. AUTOMATICALLY GENERATED. IF YOU NEED TO MAKE A CHANGE PLEASE USE THE INCLUDE FILES.

Now also the below Include files do not show on the main servers hostname so I chose MyDomainName to install the web interface on.

I saw the below information in the httpd.conf file on the domain name I wanted to install nagios login on:
Include "/usr/local/apache/conf/userdata/.conf"
Include "/usr/local/apache/conf/userdata/
.owner-root"
Include "/usr/local/apache/conf/userdata/std/.conf"
Include "/usr/local/apache/conf/userdata/std/
.owner-root"
Include "/usr/local/apache/conf/userdata/std/2/.conf"
Include "/usr/local/apache/conf/userdata/std/2/
.owner-root"
Include “/usr/local/apache/conf/userdata/std/2/username/.conf"
Include "/usr/local/apache/conf/userdata/std/2/username/MyDomainName.com/
.conf”

I added the web interface to a users domain name per below:
mkdir -p /usr/local/apache/conf/userdata/std/2/username/MyDomainName.com/
touch nagios.conf

I added the below code in the nagios.conf file:
pico nagios.conf

ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

<Directory “/usr/local/nagios/sbin”>
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Alias /nagios /usr/local/nagios/share

<Directory “/usr/local/nagios/share”>
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /usr/local/nagios/etc/htpasswd.users
Require valid-user

Then I ran this command which updated the httpd.conf file:
/scripts/ensure_vhost_includes --all-users

Now when trying to access the web interface here: MyDomainName/nagios/
I get the below error in firefox:

500 Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@MyDomainName.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

The apache error log shows the below result:
pico /usr/local/apache/logs/error_log

[Sat Nov 13 03:21:11 2010] [error] [client 222.444.333.000] SoftException in Application.cpp:256: File "/usr/local/nagios/share/inde$
[Sat Nov 13 03:21:11 2010] [error] [client 222.44.333.000] Premature end of script headers: index.php
[Sat Nov 13 03:21:11 2010] [error] [client 222.44.333.000] File does not exist: /home/username/public_html/500.shtm

Now I have researched google for the last 2 days and am stuck at this point. Any guidance would be highly appreciated. Thanks again.