What what what, it's time for a new question


#1

first of all i want to thank all the forum users, cause you help me a lot.

question number 1
-----------------------
when i get the mail with the notifications i don’t get all the information
all i get is
***** Nagios *****

Notification Type: PROBLEM

Service: CHECK_CPU
Host: Stage-Win
Address: xxxxxxxxxx
State: CRITICAL

Date/Time: $

Additional Info:

$

i want those $ signs replaced by the real informations

question 2 [the big one]

i’ve installed nrpe_nt on a windows 2000 host
configured, tested (via command line, BUT on the w2k host)
enabled the host where nagios resides
BUT
the nrpe_nt.log file keep saying that
2006-03-02 17:36:44; 988; 4;Host xxxxxxxxxx is not allowed to talk to us!

any idea?


#2

Look at your misccommands.cfg for your notify-by-email script and fix it.
It’s your macros that aren’t correct. I suspect they are from v1.x and you are using 2.x now.

It should looke something like this:

define command{
command_name notify-by-email
command_line /usr/bin/printf “%b” “***** Nagios ***\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\n\nDate/Time: $LONGDATETIME$\n\nAdditional Info:\n\n$SERVICEOUTPUT$" | /bin/mail -s " $NOTIFICATIONTYPE$ alert - $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **” $CONTACTEMAIL$


#3

question 2 could be a great number of things. REad the README that comes with nrpe and make sure you did everything.

  1. Add a line to your /etc/services file as follows (modify the port
    number as you see fit)

     nrpe            5666/tcp        # NRPE
    

    If your system uses xinetd instead of inetd, you’ll probably
    want to create a file called ‘nrpe’ in your /etc/xinetd.d
    directory that contains the following entries:

     # default: on
     # description: NRPE
     service nrpe
     {
             flags           = REUSE
             socket_type     = stream
             wait            = no
             user            = <user>
             server          = <nrpebin>
             server_args     = -c <nrpecfg> --inetd
             log_on_failure  += USERID
             disable         = no
             only_from       = <ipaddress1> <ipaddress2> ...
     }
    

I suspect nrpe.cfg
allowed_hosts=127.0.0.1


#4

first question -> OK! waiting for the new notific.
2nd question -> working on it

NEW quest.
why does my nagios is one hour ahead? if it’s 8am he says it’s 9am
(the timezone is correct)
what can i do?


#5

Daylight savings problem? There is nothing to set the time in nagios. It gets it with the system. Type:
date
at a command line to make sure it’s setup to correct time.