Windows 2000 server


#1

I have one windows 200 server (yes it is 8 years old) which is running some critical service and need to be monitored by nagios. I use the Nsclient++ with 12489 port like my other windows 2003 server but I could not get this work. nagios complains with connection refused and I instantly look into firewall all turned off. Are there different client to monitor windows 2000 server or i am doing something wrong unknowingly.

Thanks guys,

Madal


#2

Win2k should work with nsclient… can you telnet to the server on 12489 (from nagios? Locally?)? Can you see the port is open and listening using netstat -a?

HTH

/S


#3

when I telnet from nagios server to all the windows 2003 server its get connected but cannot connect to the server from teleneting from windows 2003 servers. However windows 2003 server are reporting properly though.

With regard to windows 200server no I cannot telnet to 12489 port from server to the client eventhough I turn off the firewall.

Let say if windows 2003 server (that are working) should they also able to telnet to the nagis server ? if thats the case then something is really not working somewhere.

Madal


#4

No, you won’t be able to telnet back from the w2k client to nagios, so don’t worry about that… it sounds like the port isn’t listening on your w2k server… did you run a netstat -an on the w2k server? You should see <your server’s IP address>:12489


#5

you are probably right - here is what i get by doing netstsat on the problem client
TCP 0.0.0.0:12489 0.0.0.0:0 LISTENING.

One thing, I installed the Nsclient on Z: drive (that should not be a issue because service is running fine).

PS : but when i turn off firewall it should be fine - am i right ?

Any inputs would be great.

Regds,
Madal


#6

Well, that looks like it should be fine, i think that means it is listening on all addresses, so if you turn the firewall off then you should be able to establish a connection right enough. So, you might want to check nsc.ini and confirm
[blockquote][NSClient]
;# ALLOWED HOST ADDRESSES
; This is a comma-delimited list of IP address of hosts that are allowed to talk to NSClient deamon.
; If you leave this blank the global version will be used instead.
;allowed_hosts= [/blockquote]is correct…
Also, maybe look at specifically binding the nsclient service to a particular interfaces IP address by configuring** bind_to_address=** which is just below that.
I assume that normal connectivity is fine between your nagios server and your w2k server, i.e. ping works fine, and there’s no intermediate routing or firewall problems or anything, and that the w2k server knows the route back to the nagios server? Although to be honest, connection refused would seem to indicate the traffic* is* getting there OK and being rejected rather than getting lost en route. Also, set up the log file and see if anything pertinent appears in there…
Another thing you could try would be to change nsclient to another port, that might help. I once had a server where nsclient had crashed and held the port open and even though it would seem to ‘restart’ and run ok, nothing worked. I couldn’t reboot the thing so I just moved the service to 12490 instead and reconfigured the checks and it was all fine after that…

NSClient is great when it works, but a right pain when it doesn’t. :frowning:


#7

Thanks,

I fixed this problem. This is what I did. I removed the NSclient from the host and re-installed again with the default port 12489. I used IPsec for firewall however old admin guys had also implemented TCP filters in network interface TCP/IP properties in windows 2000 server.
like this
. Click Start , point to Settings , click Control Panel , and then double-click Network and Dial-up Connections .
2. Right-click the interface on which you want to configure inbound access control, and then click Properties .
3. In the Components checked are used by this connection box, click Internet Protocol (TCP/IP) , and then click Properties .
4. In the Internet Protocol (TCP/IP) Properties dialog box, click Advanced .
5. Click the Options tab.
6. Click TCP/IP filtering , and then click Properties .
7. Select the Enable TCP/IP Filtering (All adapters) ch

As soon as i remove this bit - nagios starting to rock. Thanks for your help.

You guys awesome!!!

Have a good weekend

Madal