Won't authenticate users


#1

Just recently set up Nagios 3.0.2 on Ubuntu 6.10 and cannot login. Keeps asking for username/password. I checked /var/log/apache2/error.log and sure enough it has the following error:
(2) Could not open password file: /usr/local/nagios/etc/htpasswd.users
user nagiosadmin not found: /nagios

I did create the user ‘nagiosadmin’ using htaccess and the user is listed in htpasswd.users. The cfg.cgi file has that user authorized for all actions. I noticed that the htpasswd.users file was owned by root:root so I tried nagios:nagios and www-data:www-data and that didn’t fix it either. I’ve even tried doing chmod 777 to make sure it is not a permissions issue and that didn’t do it either.

Can someone please help me? I’m really close to wiping it out and starting fresh, but I’m sure I followed the directions carefully the first time around. I used the following guide: nagios.sourceforge.net/docs/3_0/ … buntu.html

Thanks in advance.
Mike


#2

check your apache httpd.conf file and check for the nagios portion (installed using make) and then look for authentication method.


#3

I ended up reinstalling everything and it seems to be working now. I’m able to authenticate to it. Something must have been missing I suppose.